Shastix Forums
   Shastrix.com   |   Shastrix Forums    Register   |    Sign In  

Weird stats in Technical Support Pages: 1 Reply

B.T. Isaac
Avatar
Artist

Posts: 346
   10th October 2008, 15:49    
The stats page is showing something strange. It's displaying multiple users a single visitor and even displays the browser incorrectly. For example, Jim and I are show up as a single user and 'Googlebot' is written below 'Browser'. There also appears to be an impossibly small amount of visitors since this started. Could anyone tell me what's going on?
 
     
 
Jim
Avatar
Site Owner

Posts: 380
   10th October 2008, 20:40    
Interesting...

It looks like something weird happened yesterday with the stats recording and so all our visits have been lumped together - I'll have to have a look if I can get a moment this evening.

As for the Googbot, that is a valid browser, as the stats reflect every visit to the site, including bots as well as real people.
 
     
 
B.T. Isaac
Avatar
Artist

Posts: 346
   10th October 2008, 21:33    
I know it shows bots as well, but I'm not a bot. And 'Googlebot' is written as one of our browsers.
 
     
 
Jim
Avatar
Site Owner

Posts: 380
   11th October 2008, 01:10    
I've had a bit of an investigate and the only conclusion that I can come to is that the company that provides our hosting has decided to divert all our users through a proxy server before putting you through to the site. This means that the site's stats record all the visits as coming from the same place (well, three, but they look like they're all the same server).

The way that the site stats work is to assume that the first browser used each day is the same one that you will use for every visit that day... this can possibly be changed to list each browser separately, but at the moment I can't find any way to identify individual visitors unless they are signed in, when we can use their username as an identifier.
 
     
 
B.T. Isaac
Avatar
Artist

Posts: 346
   11th October 2008, 04:54    
That sounds pretty much what I've seen, so it's most likely the cause.
 
     
 
Weird stats in Technical Support Pages: 1 Reply